Ana Sayfa Bilgisayar Microsoft Excel Formülleri ve Yazma Kuralları

Microsoft Excel Formülleri ve Yazma Kuralları

131
0
Paylaş

Formül yazmak için “Formül Araç Çubuğu” kullanılır, ya da hücre içerisine çift tıklanarak formül yazılır.

Formüller = eşittir işareti ile başlar.

Formüllerde hücrede bulunan sayı değeri yerine hücrenin adresi ( A1, A2 gibi) kullanılır.

Formüllerde kullanılan operatörler;

Toplama +

Çıkarma

Çarpma *

Bölme /

Sayının üssü ^

Formüllerde kullanılan işleçler;

Küçüktür <

Büyüktür >

Küçüktür ve eşittir <=

Büyüktür ve eşittir >=

Eşittir =

Eşit değildir <>

Hücre adresini sabitlemek için $ işareti kullanılır. $A$1

Satırı ve Sütunu sabitlemek için: $B$1

Satırı sabitlemek için: B$2

Sütunu sabitlemek için : $B2

Hücre adresini sabitlemek için $ işareti kullanılır. $A$1

Satırı ve Sütunu sabitlemek için: $B$1

Satırı sabitlemek için: B$2

Sütunu sabitlemek için : $B2

Operatörlerin yazılışları aşağıdaki tablodaki gibi ;

Sonuçlar ise ;

Formüllerde kullanılan ayraçlar;

“”→Metin içeren ifadeleri ayırmak için kullanılır.

Örnek : =EĞERSAY(A1:A10;”Takdir”)

Açıklama: A1 ve A10 hücreleri arasında değeri “Takdir” olan hücrelerin sayısını verir.

( ) →Formülü gruplandırmak için kullanılır.

Örnek : =2*A1+(A2+A3)/3:

→Belli birhücre aralığını seçmek için kullanılır.

=B1:B5 → B1 hücresinden başlayarak B5 hücresine kadar olan bütün hücreleri seçer.

Örnek-1 :=TOPLA(A1:A10)

Açıklama:A1 hücresinden başlayarak A10 hücresine kadar olan bütün hücrelerdeki değerleri toplar.

Örnek-2:=ORTALAMA(A1:A10)

Açıklama:A1 hücresinden başlayarak A10 hücresine kadar olan bütün hücrelerin ortalamasını alır. ;

→Farklı hücreleri seçmek için kullanılır. =A1;A10 → Sadece A1 ve A10 hücresi seçilir. =A1;B5 → Sadece A1 ve B5 hücresi seçilir.

Örnek-1 :=TOPLA(A1;A10)

Açıklama:Üstteki örnekte aralıktaki tüm hücrelere toplamaya dahil edilirken bu formülde; noktalıvirgül işareti kullanıldığından dolayı sadece A1 ve A10hücresindeki değerler toplanır.

Örnek-2:=ORTALAMA(A1;A10)

Açıklama:Bu örnekte sadece A1 ve A10 hücresindeki değerlerin ORTALAMASI alınır. Aralıktaki diğer hücreler ortalamaya dâhiledilmez.

Örnek formül yazımları;

Formül sonuçları;

Fonksiyon:Daha önceden tanımlanmış, kullanıcıdan aldığı verileri hesaplayarak tek bir sonuç üreten ve bu sonucu ekrana yazan komuttur. Fonksiyon dört parçadan oluşur;

1.= işareti

2. Fonksiyon adı

3. Parantezler

4. Argümanlar Excel’de kayıtlı olan fonksiyonları görmek için Formül çubuğundan  “Fonksiyon Ekle”düğmesi tıklanarak kayıtlı fonksiyonlar görüntülenir.

Başlıca kullanılan fonksiyonlar;

1.TOPLA Fonksiyonu:

Kullanılışı:Kullanıcının girdiği verileri toplayarak toplam sonucunu ekrana yazar. Birden fazla veri girişi yapılabilir.

Örnek:

=TOPLA(12;40;20+10;20/5)

Farklı hücre adreslerini toplamak için ; noktalı virgül kullanılır.

=TOPLA(Sayı1 ; Sayı2; Sayı3; ….. )

Örnek: =TOPLA(A1;A4;B5;C2+D2;E5)

→Farklı değerleri veya hesaplamaları (;) noktalı virgül kullanarak birbirinden ayırmak gerekir.

Belli bir hücre aralığını toplamak için ise (:) iki nokta üst üste işareti kullanılır.

=TOPLA(Başlangıç hücresi: Bitiş Hücresi)

Örnek:

=TOPLA(C2:C7) → C2Hücresinden başlayarak C7hücresine kadar olan bütün değerleri toplar.

2.ORTALAMA Fonksiyonu:

Kullanılışı:Kullanıcının girdiği verilerin ortalamasını alır.

=ORTALAMA(Sayı1; Sayı2; Sayı3;…..)

=ORTALAMA(20;50;70)

=ORTALAMA(A2;C5;B10)

=ORTALAMA(Başlangıç hücresi :Bitiş Hücresi)

=ORTALAMA(A1:A10)

NOT: Eğer bir hücrenin değeri boş ise ortalamaya dahil edilmez. Eğer hücre ortalamaya dahil edilecekse değeri sıfır olmalıdır, boş bırakılmamalıdır.


Farklı hücre adreslerinin ortalamasını almak için (;)noktalı virgül kullanılır.

=ORTALAMA(A1;B5;C2)

Belirli bir hücre aralığının ortalamasını almak için (:) iki nokta üst üste işareti kullanılır.

=ORTALAMA(B1:B10)

Birden farklı alanların, değerlerin ve hücre adreslerinin ortalamasını almak için işlemler arasına (;) işareti konur.

=ORTALAMA(A1:A5;B2:B10;C5; 100)

3.MAK Fonksiyonu:

Kullanışı: Belirtilen sayılar arasındaki EN BÜYÜK sayı değerini ekrana yazar. Belirli bir aralıktaki EN BÜYÜK sayı değerini hesaplamak için (:) iki nokta üst üste işareti kullanılır. Farklı hücre değerlerini yazmak için ise (;) noktalı virgül işareti kullanılır.

=MAK(Sayı1;Sayı2;Sayı3;….)

=MAK(Başlangıç Hücresi : Bitiş Hücresi )

Örnekler:

=MAK(A2;B2)

=MAK(A2:D2)

4.MİN Fonksiyonu:

Kullanışı: Belirtilen sayılar arasındaki EN KÜÇÜK sayı değerini ekrana yazar. Belirli bir aralıktaki EN KÜÇÜK sayı değerini hesaplamak için (:) iki nokta üst üste işareti kullanılır. Farklı hücre değerlerini yazmak için ise (;) noktalı virgül işareti kullanılır.

=MİN(Sayı1;Sayı2;Sayı3;….)

=MİN(Başlangıç Hücresi : Bitiş Hücresi )

Örnekler :

=MİN(A2;B2)=MİN(A2:D2

5.YUVARLA Fonksiyonu:

Kullanılışı; Ondalıklı bir sayının virgülden sonraki kısmının kaç basamak yuvarlanacağını belirtmek için kullanılır.

=YUVARLA(Sayı; Ondalık basamak sayısı)

=YUVARLA(3,5768989;2) ->Bu formülde virgülden sonra 2 basamak yuvarlatılmak istenmektedir. Sonuç : 3,58 ‘dir. YUVARLA fonksiyonu yarımdan sonraki değerleri YUKARIYA yuvarlarken, yarımdan önceki sayıları AŞAĞIYA yuvarlar.

6- AŞAĞIYUVARLA Fonksiyonu:

Kullanılışı; Ondalıklı bir sayının virgülden sonraki kısmının kaç basamak AŞAĞIYA yuvarlanacağını belirtmek için kullanılır.

=AŞAĞIYUVARLA(Sayı; Ondalık basamak sayısı)

=AŞAĞIYUVARLA(3,5768989;2) -> Bu formülde virgülden sonra 2 basamak aşağı yuvarlatılmıştır.

7 .YUKARIYUVARLA Fonksiyonu:

Kullanılışı; Ondalıklı bir sayının virgülden sonraki kısmının kaç basamak YUKARIYA yuvarlanacağını belirtmek için kullanılır. =YUKARIYUVARLA(Sayı; Ondalık basamak sayısı)

=YUKARIYUVARLA(3,5768989;2) -> Bu formülde virgülden sonra 2 basamak aşağı yuvarlatılmıştır

Yuvarlama fonksiyonlarına örnek;

NOT: Eğer ondalık kısım tamamen atılmak isteniyorsa basamak sayısı olarak sıfır değeri girilmelidir.

Örnek: =YUVARLA(3,369876;0)

Ondalıklı kısım iki basamak istenirse;

EXCEL ŞARTLI DEYİM FONKSİYONLARI:

1.VE Fonksiyonu:

Kullanılışı:

=VE(Şart1; Şart2;Şart3;…)

İçerisine yazılan şartlardan hepsinin gerçekleşmesi halinde sonuç DOĞRU, şartlardan herhangi birinin veya tamamının gerçekleşmemesi durumunda ise sonuç YANLIŞ olur.

Sonucun doğru olabilmesi için mutlaka ve mutlaka içerisine yazılan bütün şartların gerçekleşmesi gerekir.

Örnek: Bir idarecinin nöbetçi öğrenciden istediği “Ali VEAyşe gelsin..” cümlesinde şartlardan her birinin gerçekleşmesine bağlı olarak sonuçları tabloda gösterelim.

=VE(Ali=”Geldi”;Ayşe=”Geldi”)


Tabloda görüldüğü üzere sonucun doğru olabilmesi için her iki şartın gerçekleşmesi (Ali ile Ayşe’nin gelmesi) gerekiyor.

Fonksiyon formülünü yazacak olursak ;

=VE(Ali=”Geldi”;Ayşe=”Geldi”)

Uygulama-1: Boy bilgisini değerlendirmek için yapılan uygulamalarda boy aralıkları fonksiyon içerisine yazılarak sonuçlar değerlendiriliyor.

Uygulama-2: Not aralıklarını kontrol eden bir uygulama.

2.YADA Fonksiyonu:

Kullanılışı:

=YADA(Şart1; Şart2;Şart3;…)

İçerisine yazılan şartlardan herhangi birinin gerçekleşmesi veya birkaçının gerçekleşmesi halinde sonuç DOĞRU, şartların tamamının gerçekleşmemesi durumunda ise sonuç YANLIŞ olur.

Sonucun doğruolabilmesi için bir veya birkaç şartın gerçekleşmesi yeterlidir.

Örnek: Bir idarecinin nöbetçi öğrenciden istediği “Ali YADA Ayşe gelsin..” cümlesinde şartlardan her birinin gerçekleşmesine bağlı olarak sonuçları tabloda gösterelim.

=YADA(Ali=”Geldi”;Ayşe=”Geldi”)

Tabloda görüldüğü üzere sonucun doğru olabilmesi için herhangi bir şartın veya şartlardan her ikisinin gerçekleşmesi yeterlidir.

Fonksiyon formülünü yazacak olursak ;

=YADA(Ali=”Geldi”;Ayşe=”Geldi”)

Uygulama-1:

3.EĞER Fonksiyonu :

Kullanılışı: Bir şartın gerçekleşmesi veya gerçekleşmemesi durumunda yapılacak işlemleri ekrana yazmak için kullanılır. Eğer şart doğruysa DOĞRU değeri , eğer şart yanlışsa YANLIŞ değeri ekrana yazar.

İç içe birden fazla EĞER fonksiyonu kullanılabilir.

=EĞER(Şart; Şartın doğru olması durumunda yapılacaklar;Şartın yanlış olması durumunda yapılacaklar)

=EĞER(ŞART; Olumlu Değerler; Olumsuz Değerler)

=EĞER(ŞART;DOĞRUDEĞER ;YANLIŞDEĞER)

NOT: Formülü yazarken metin içeren değerler çift tırnak “” içerisinde yazılmalıdır.

=EĞER(B2>=50;”Geçti”;”Kaldı”) formülünde ;

Şart -> Not>=50 Şart gerçekleştirildiğinde yazılacak değer-> GEÇTİ

Şart gerçekleşmemesi durumunda yazılacak değer-> KALDI

Örnek : Boyu 150 cm ve aşağısı olanlar için “Kısa” , 150’den büyük olanlar için “Normal” yazan Excel tablosunu oluşturalım.

=EĞER(A2>150; “Normal”;“Kısa”)şeklinde veya

=EĞER(A2<=150;“Kısa”;“Normal”)şeklinde her türlü biçimde yazılabilir.

4.EĞER Fonksiyonunun iç içe kullanılması:

Birden fazla şartın sorgulanması gerektiğinde EĞER fonksiyonu iç içe kullanılır. Yani şart içerisinde , o şarta bağlı başka şartları da kontrol etmek istediğimizde iç içe EĞER fonksiyonunu kullanırız.

=EĞER(Şart1; “Olumlu eğer”; EĞER(Şart2; “Olumlu Değer”;EĞER(Şart3;”Olumlu Değer”; Olumsuz Değer”)))

Formülün yazımında en sonunda “Olumsuz değer” mutlaka belirtilmelidir. Yazdığımı her EĞER sorgulaması kadar formülün sonuna parantez işareti konmalıdır.

Örnek: Not ortalamasını tek bir formül yazarak değerlendirelim..

Örnek Uygulama-1: Aşağıda verilen Excel tablosunda yaşı 26’dan küçük eğitim lisans olanlar ve erkek olanlar için “iş başvurunuz kabul edildi” açıklaması yazacak, şartlar uymuyorsa “iş başvurunuz kabul edilmedi” şeklinde açıklama yazılacak.

Yazılacak olan formül:

=EĞER(VE(C3=”Lisans”;B3<26;D3=”Erkek”);”İş başvurunuz , kabul edildi…”;”İş başvurunuz kabul edilmedi… “) şeklinde olacak.

ŞART :VE(C3=”Lisans”;B3<26;D3=”Erkek”)

Olumlu Değer: “İş başvurunuz , kabul edildi..”

Olumsuz Değer: “İş başvurunuz kabuledilmedi…”

Örnek Uygulama-2: Aşağıdaki alacak-borç tablosunda tablodaki bilgilere bakarak “alacaklıyız” veya “borçluyuz” açıklamasını yazdıralım

Formülde şart cümlesini yazarken dikkat etmeliyiz. Alacağımızdan borcumuzu çıkarırsak sonuç ortaya çıkar,eğer eksi(-) bir değer çıkarsa “borçluyuz” demektir. Ancak (+) bir değer çıkarsa alacaklıyız demektir. Değer sıfıra eşitse ne alacak, nede verecek yok demektir.

ŞART: Alacak-borç <0 ise yani B3-C3<0 ,

Olumlu Değer: “Borçluyuz”

Olumsuz Değer: “Alacaklıyız”

Formülü şu şekilde değiştirirsek, sonucun sıfır olduğu durumlarda “alacak da verecek de yok” yazabiliriz.

=EĞER(B3-C3<0;”Borçluyuz”;EĞER(B3-C3=0;”alacak da verecek de yoktur”;”Alacaklıyız”))

Örnek Uygulama-3: Aşağıdaki tabloda memleketi “samsun”olanlar için “hemşehrimiz”, olmayanlar için ise “yabancı” açıklamasını yazdıralım.

=EĞER(B2=”samsun”;”Hemşehrimiz”;”yabancı”) şeklinde veya

=EĞER(B2<>”samsun”;”yabancı”;”Hemşehrimiz”) şeklinde yazılabilir.

Örnek Uygulama-4:

Aşağıdaki tabloda amaçeşi çalışmayanlara bürüt maaş +100 tl kadar aile yardım yapılması. Eğer kişinin eşi çalışmıyorsa maaşına 100 TL aile yardımı eklenecek, eğer çalışıyorsa maaşı aynen kalacak hiçbir değişiklik olmayacak.

Formülü

=EĞER(C2=”hayır”;B2+100;B2)şeklinde yazabiliriz.

ŞART: eşi çalışıyormu= “hayır” yani C2= “hayır”

Olumlu Değer: maaş+100 yani B2+100

Olumsuz Değer: maaş değişmeyecek yani B2

Örnek Uygulama-5: Aşağıdaki örnekte medeni hali evli , 2 çocuğu olan ve eşi çalışmayan kişilere kira yardımı yapılacak, bu şartları taşımayanlara ise kira yardımı alamaz şeklinde açıklama yazılacak.

Formülü yazarken şartların hepsini taşıması istendiği için birden fazla olan şartlarımızı VE fonksiyonu içerisinde yazmamız gerekiyor.

ŞART lar:

medeni hali =evli

Çocuk sayısı >=2

Eşi çalışıyor mu? = hayır

VE(B2=”evli”;C2>=2;D2=”hayır”)

Olumlu değer : “kira yardımı alacak”

Olumsuz değer: “yardım alamaz…”

5.EĞERSAY fonksiyonu:

Belli bir hücre aralığında belirtilen değerlerin sayısını verir.

=EĞERSAY(Aralık ; Ölçüt)

Örnekler:

=EĞERSAY(A1: A100 ; “Takdir”) formülüyle A1 hücresinden A100 hücresine kadar olan bütün hücrelerde “Takdir” kelimesi yazan hücrelerin sayısını verir.

=EĞERSAY(A1: A100 ; 100 ) formülüyle A1-A100 aralığında kaç tane 100 sayısı olduğunu hesaplar.

=EĞERSAY(A1: A100 ; “>50”) formülüyle A1-A100 aralığında 50’den büyük değerlerin sayısını verir.

=EĞERSAY(A1:A100; “>50”)-EĞERSAY(A1:A100; “>=100”)formülüyle A1-A100 aralığında 50-100 sayıları arasında kaç tane değer olduğunu hesaplar. Aralığa 50 ve 100 sayısıdahil değildir. 50 ‘den büyük değerlerin sayısından 100’den büyük sayıların çıkarılması ile hesaplanır.

6.BOŞLUKSAY fonksiyonu:

Belirtilen aralıktaki boş hücrelerin sayısını verir.

=BOŞLUKSAY(A1:A100)

7.EBOŞSA fonksiyonu: Bir hücre eğer boş ise DOĞRU değerini , DOLU ise YANLIŞ değerini döndürür.

=EBOŞSA(A1)

Aşağıdaki örnek hücre boş bırakılırsa “boş bıraktınız” çeklinde açıklama yazdırabilirsiniz veya hücre içerisini boş bırakabilirsiniz..

=EĞER(EBOŞSA(B2);”boş bıraktınız”;EĞER(B2>=50;”GEÇTİ”;”KALDI”))

Eğer ortalama boş ise formülün olduğu açıklamayı boş bırakmak için ise

=EĞER(EBOŞSA(B2);””;EĞER(B2>=50;”GEÇTİ”;”KALDI”))şeklinde düzenleyebiliriz.

Kaynak: Selami DURSUN